Author Topic: bike slightly holds back when opening the throttle / misfire ???  (Read 329 times)

Gixxer600k7

  • Newbie
  • *
  • Posts: 3
Hi everyone, hoping someone can shed some light, my z1000 2003 holds back slightly as Iím opening the throttle, I donít think itís in all gears, Iíve felt this via 2nd and 3rd gears, but Iím going to check to see if it does it in other gears over the next few rides, whilst idling, if you turn the throttle it seems like it holds back to, itís only a slight moment, hope this makes sense.  Iíve had the bike for 3 months and the previous owner put a set of cans on it, a pc3 and has told me itís also got iridium plugs and an aftermarket filter.  can it be the plugs.  It seemed like it was running very rich as it was heavy on fuel, so someone suggested to change the map, I emailed dyno jet and subsequently they sent me a suitable map, after working out how to upload it the bike seems a lot smoother but the slight hesitation is still present.    thankis

Repsolvan

  • Committee
  • Sr. Member
  • *****
  • Posts: 462
  • Fireblade, Tuono 1000R
Re: bike slightly holds back when opening the throttle / misfire ???
« Reply #1 on: May 18, 2017, 05:23:11 PM »
One step at a time....take out the pc3 out exclude a fault with that and then put baffles in exhaust if there missing as lack of back pressure can cause lag.. check for pinched fuel hoses.. clean fuel filter if fitted...check pump primes fuel rail if fitted....usual check on fuses.... ensure your battery is secure and connections are tight... ensure battery condition is ok -static and running- then check reg rec.....then move on to plugs n leads connections ...  its still make be a crap connector electrically so keep looking and tick off your list before you start getting into the engine..... wet clutch may have wrong oil... check exhaust temp on each cylinder if difference seen changes plugs then looks at valve clearances .. my experience with gears is generally you cant change up and or down and or miss gears regularly   3rd gear known on some bikes ... anyway im now rattling....
  hope this helps best of luck 🖒🖒🖒🖒🏍🏍🏍
Live life fast and loud

Caddy948

  • Full Member
  • ***
  • Posts: 219
Re: bike slightly holds back when opening the throttle / misfire ???
« Reply #2 on: May 18, 2017, 07:11:56 PM »
An idea...Could there be some play in the throttle cable?

Dave